close Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Opened 14 years ago

Closed 14 years ago

#5 closed (fixed)

No search path for static files

Reported by: cmlenz Owned by: cmlenz
Priority: major Milestone: 1.0
Component: static Keywords:
Cc:

Description

Currently an application can provide a list of static directories to search for static file requests (under /media by default). The problem is that for production, you'd want to use a “real” web server to serve those files instead, and for that the different static dirs need to live in separate URL spaces.

So the static dirs specification should include e.g. a path prefix for every directory, and duplicate path prefixes would not be allowed.

Change History (1)

comment:1 Changed 14 years ago by cmlenz

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r59.

Note: See TracTickets for help on using tickets.